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Why Arduino?

Physical Computing

e uses electronics

e to prototype new materials

o for designers and artists.
Tinkering

Patching

Community

 Blog, Forum, Playground (wiki)
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Hardware

Arduino Uno Arduino Lil}'Pad Arduino Fthernet Arduino Nano Arduino BT Arduino Mini

Axtinion MoE 00 Arduino BT Arduino Mini USB/Serial Light Adapter Arduino Pro Mini

Arduino Mega ADK

USB/Serial Light Adapter Arduino Pro Mini
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UNO

Microcontroller

Operating Voltage

Input Voltage (VIN) (recommended)
Input Voltage (limits)

Digital I/0O Pins

Analog Input Pins

DC Current per 1/0 Pin

DC Current for 3.3V Pin

Flash Memory

SRAM (Static RAM)

EEPROM (Electrically erasable
programmable ROM)

Clock Speed

Department of Industrial Design

ATmega328
5V

7-12V

6-20V

14 (of which 6 provide PWM output)
6

40 mA

50 mA

32 KB (ATmega328) of which 0.5 KB
used by bootloader

2 KB (ATmega328)
1 KB (ATmega328)

16 MHz
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UNO

 Power: USB Power supply (5V)
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UNO

 Power: external power supply (7V-12V)
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UNO

 Power: VIN, input or supply, depending on external
power source. (7-12V)
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 Power: 5V supply
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 Power: 3.3V supply
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UNO

 Power: GND pins
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UNO

« Digital I/0O Pins 14 (of which 6 provide PWM output)
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UNO

« Digital I/0O Pins 14 (of which 6 provide PWM output)
« PWM (Pulse-width modulation)
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UNO

e Serial: 0 (RX) and 1 (TX)
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UNO

* 6 analog inputs, 10 bits of resolution (i.e. 1024
different values)
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UNO

Reference voltage for the analog inputs
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UNO

» Reset. LOW to reset the microcontroller

MADE
IN LTALY

. ax e ARDUINO
&
o Wl W e (e

G’ ™

Technische Universiteit
Eindhoven
University of Technology

Department of Industrial Desig 17-12-2015  PAGE 18



Software: IDE

e http://arduino.cc/en/Main/Software

File Edit Sketch Tools Help

| Technische Universiteit
ce e Eindhoven
University of Technology
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http://arduino.cc/en/Main/Software

Driver Installation and Port Identification

» Refer to the instructions in
o “Getting Started with Arduino”, page 23-26
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Breadboard




Color coding of the resistors

L B 1% S0
01z +2v IR |
0 Al 0| &
1 107 Eioz] [ 1]
2 I
3 [
4 [ Yellow IL EHH%EI!FE Léé& Exnﬁlﬁz lEé gTh EEH%I?'LIIS
5 ] Green
6 Jl Blue l [ [ EETE i |
7 I Purple HE T z2|z]z[x100 Eﬂﬂm
8 [ Grey DEII:I El El El BRI El El El EREEIE
9 [ White [#][#][<10000] [2][g][8][F10000] (2] [#] [#] [ 10000]
II_ ElEEl[=10] El E] [E] [=10]
+1% [ Brown w 1000000
+2% [l Red HEED HEH HEH
*5% [ ] Gold [El[E][=100] EIEE [E][E] [E]
+10% [ ] Silver [=1[5] ElEE) El|ElE]
Color Codes 4 Band Resistors | 5 Band Besistors | 6 Band Resistors
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Really getting started

Sense/ Perceive

""-m,_\_\\_‘-‘_\_

|ensor‘s I/_\/\/__\

"‘———__ﬁ_____ | |\
/ Behavior
(software) g//

I
—*""\ ,/‘“x—/
Actuators

Act./React
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Blinking an LED

* File>Examples>Basics>Blink

e LED: light-emitting diode
(@ Biink | Arduino 0022 --ilglélgﬂ

File Edit Sketch Tools Help

Elink
Turns on an LED on for one second, then off for one second, repe

Thiz exanple code iz in the public domain.
L

void setup () {
Jf initialize the digital pin as an output.
/¢ Pin 13 has an LED comnected on most Arduino boards:
pinMode (13, OUTPUT) :

}

void loop() |
digitalWrite (13, HIGH): zet the LED on
delay(1000) wait for a second
digitalWrite (13, LOW); zet the LED off
delay(1000) wait for a second

Technische Universiteit
Eindhoven
University of Technology
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Blinking an LED
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Blink an LED

» #define LED 13

#define LED 13

vold =setup() |
S/ dinitialize the digital pin asz an output.
A4 Pin 13 has an LED comnected on most Arduino boards:
pinMode (LED, OUTEUT) :

void loop()
digitalllrite (LED, HIGH) £4 set the LED on

delay (1000 ; A5 wait for a second
digitalllrite (LED, LOT ; £4 set the LED off
delay (1000 ; A5 wait for a second
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Button to control the LED

* File>Examples>Digital>Button
(@ sutton Ao 022 el

File Edit Sketch Tools Help

W

Button

Turnz on and off a light emitting diode(LED)] connected to digital=
pin 13, when pressing a pushbutton attached to pin 2. 1

The circuit:

* LED attached from pin 13 to ground

* pushbutton attached to pin 2 from +5V

* 10K reszistor attached to pin 2 from ground

* Note: on most Arduines there iz already an LED on the bhoard
attached to pin 13.

created Z005
by DojoDave <http: //wmnr, 090, org-
wodified 28 0Oct 2010

br Tom Trine
4|
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Button to control the LED
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Button to control the LED

A4 constants won't change. They're used here to

Af zet pin numbhers:

const int buttonPin = 2: A4 the mamber of the pushbutton pin
const int ledPin = 13; A7 the nmumber of the LED pin

Af wariables will change:
int buttonitate = 0; A4 wariable for reading the pushbutton status

volid setup () {
A 1nitialize the LED pin as an output:
pinMode (ledPin, OUTPUT)
A d1nitialize the pushbutton pin as an input:
pinfode (buttonPin, INPTUT);
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Button to control the LED

vold loop ()
A4 read the state of the pushbutton walue:
buttonitate = digitalFead(buttonPin):

A7 check if the pushbutton is pressed.
A 1f it 1z, the buttonitate i3z HIGH:
if [(button3tate == HIGH] {

A4 turn LED on:

digitalllrite (ledPin, HIGH) :
i
elze

A4 turn LED off:

digitalllrite (ledPin, LOW :

Department of Industrial Design
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Analog 1I/O

* File>Examples>Analog>Analoglnput

* Instead of a potentiometer, we use a light sensor
AnaIDgInpuﬂArduinoOﬂm 1_@@&‘

File Edit Sketch Tools Help

Analog Input

Demonstrates analog input by reading an analog sensor on analog pin 0
turning on and off a light emitting dicde(LED) connected to digital
The amount of time the LED will be on and off depends on

the walue obtained by analogRead().

The circuit:

* Potentiometer attached to analog input 0
center pin of the potentiometer to the analog pin
one side pin (either one) to ground
the other =zide pin to +5V
LED anode (long leg) attached to digital output 13
LED cathode (short leg) attached to ground

* Note: because most Arduinos hawe a built-in LED attached
to pin 13 on the board, the LED iz optional.

Created by David Cuartielles
Modified 4 Zep 2010
By Ton Igoe

This example code is in the public domain.

4 | 11
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Analog 1I/O
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Analog 1I/O

int sensorPin = A40; 4 select the input pin for the potentiometer
int ledPin = 13; ff select the pin for the LED
int sensorValue = 0; /7 wariable o store the walue coming from the zensor

vold setup() |
A4 declare the ledPin as an OUTPUT:
pinMode (ledPin, OUTPIT):

vold loop () |
A4 read the walue from the sensor:
sensorValue = analogEeadi{sensorPin) ;
A turn the ledPin on
digitallrite (ledPin, HIGH) :
A/ stop the program for <sensorValue> milliseconds:
delayi(zensorvalue) ;
A/ tarn the ledPin off:
digitallrite (ledPin, LOW)
S/ stop the program for for <sensorValue> milliseconds:

delayisensorvValue) ;
} echnology

17-12-2015 PAGE 33
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Analog 1I/O

int sensorPin = A4l; 4 select the input pin
int ledPin 4-11; AF select the pin for the LED
int sensorValue = 0; // wariahle to ztore the walue coming from the zensor

volid setup() |

Sf declare the ledPin as an OUTPUT:
pinMode(ledPin, OUTPUT) :

void loop () |

A4 read the walue from the sensor:
sensorvValue = analogRead({sensorPin) ;
4 turn the ledPin on

analogiirite {ledPin, sensorValuel'd)f

Designed Technische Universiteit
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Serial Communication

 We are going to use the Serial library from
Processing to talk to Arduino
o http://[processing.org/referencel/libraries/serial/index.html

* In Processing
- File>Examples>Books>Getting Started>Ex_11 06
« You can not run this program in Processing
- Copy the code to Arduino software, upload to Arduino.
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http://processing.org/reference/libraries/serial/index.html

Serial Communication

A/ Ewample 11-06 from "Getting Started with Processing”
A by Beas & Fry. 0'BEeilly / Make 2010

A Note: This iz code for an Arduino board, not Processing

int sensorPin = 0; // Select input pin
int wal = 0;

4

void setupi) { The 'BYTE' keyward is no londger supparted.
Serial . .bhegin(9a00) ;

vold loop() |

val = analogReadisensorPin) / 4; /7 BEead wvalue from sensor
serial.printiwal, BE¥YTE): // Frint wariable to serial port
delay (100): 7/ Wait 100 milliseconds

} |

Designed Technische Universiteit
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Serial Communication

/¢ Example 11-06 from "Getting Started with P[4 comas

A7 by Beas & Fry. 0'Eeilly / Make 2010 f

e et

A Note: This iz code for an Arduino board, n|°

int sensorPin = 0; /7 Zelect input pin

int wal = 0}

void setup() !

Serial.begin(9600); S/ Open serial port

-

volid loop() |

wval = analngReadisensanin] P -

Autoscroll

-:Cérfiage return v EIEUU baud

S4 RBead walue from sensor

Ferial.println(wal) ;

A4 Print wariahle to serial port

delavy(100); S/ Wait 100 millizeconds

Department of Industrial Design
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Serial Communication

A4 Example 11-06 from "Getting Started wlmmmuw

/4 by Reas & Fry., 0'Reilly / Make 2010 { -

Z]_gbaaa”_ ~\[ZYXVIUWY\"'aaa""_~\[ZYWVOIVE[~‘abaa™"_]% *

A Note: This is code for an Arduino board,

int sensorPin = 0; /7 Select input pin
int wal = 0;

vold setup () {
Serial.begin(9e600),; S/ Open serial port

i 1 | »

Autoscroll .:Carriage return - EEIEUU baud

vold loop() |
val = analogRead(sensorPin) / 4; /) BEead walue Lrom sensor
Serial.write(wal); J/ Print wariable to serial port
delay (100) s 77 Walt 100 milliseconds

|

........ Technische Universiteit
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Serial Communication

* In Processing
 FilesExamples>Books>Chapter 11>Ex 11 07

Designed Technische Universiteit
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Serial Communication

import processing. serial.*;

Aerial port; FF Create object from Zerial class
float wal; F4 Data received from the serial port

void setup ()
size (440, 220):
A4 IMPORTANT NOTE:
Sf The first serial port retrieved by Serial.listi)
S should be wour Arduino. If not, uncomment the next
S/ line by deleting the /f before it. Fun the sketch
S/ again to see a list of serial ports. Then, change
J/4 the 0 in between [ and ] to the nunber of the port
S et ZIO11T Ariiirnn J= rontecrted o
Sfprintlni(Serial.list() )
SLring arduinoPort = Serial. lisci)[0]:
port = new Jerial(thiz, arduinoPort, 9600 ;

vold draw() !
if [(port.awvailahle() > 0) { 7/ If data iz awvailable,

val = port.read(); A5 read it and store it in wal
wal = map(wval, 0, 2535, 0, height); // Conwvert the walues Technische Universiteit
nce T U e Eindhoven
} University of Technology

rect(dl, wal-10, 360, Z0):
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Serial Communication

Nimporfs processing.serial.®;

Jerial port: J/ Create object from Zerial clas
float wal; S Data received from the serial

vold setup () !
gize (440, =220): I
S/ IMPORTANT NOTE:
S/ The first serial port retriewved by Serial.
S5 should be vour Arduino. If not, uncomment
S5 line by deleting the // before it. Run the
S/ again to see a list of serial ports. Then, change
A the 0 in between [ and ] to the nmumber of the port
A4 that your Arduino is connected fo.
printlniierial.list{)):
String arduinoPort = Zerial.liz=ti(i[1l]:

port = new Serial{this, arduinoPort, 9600);

vold draw() !
if [port.available() = 0) { // If data is awvailable,

wval = port.read(): SSP read it and store it in wal
wval = mapiwal, 0, 255, 0, height): J/ Conwvert the walue  signed Technische Universiteit
elligence e Eindhoven
1 up University of Technology

rect(40, wal-10, 360, 20):
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Serial Communication

import processing.serial.*: m&__ll___n?

Serial port; /S Create object from Serial clas
float wal: A4 Data received from the =serial

vold setup()
size (440, 220);
F# IMPOETANT NOTE:
/f The first serial port retriewed by Serial.]
A4 should be vour Arduino. If not, uncomment :
A5 line by deleting the /f before it. Bun the
S again to see a list of serial ports. Then,
A/ the 0 in between [ and ] to the number of the port
Jf that your Arduino is connected to.
printlni(ierial.lizt()):

_—

String arduinoPort = Jerial.list{][1l]:
port = new Jerialithis, arduinoPort, 2600):

vold drawi() {
background (0] ;
1f (port.awvailable() > 0] §{ // If data iz available,

wal = port.read(): S read it and store it in wal
= i . Designed Technische Universiteit
val = wap(wal, 0, 255, 0, height); // Conwvert the wvalue Intelligence TU e Eindhoven
} Group University of Technology

rect(d0, wal-10, 360, Z0):
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Serial Communication

inport processing.serial.™;

Serial port; S Create object from Serial cla:
float wal; S/ Data received from the serial

vold setup () {

size (440, 220);:

J# IMPORTANT NOTE:
A4 The first serial port retriewed by Serial . f
A4 should be your Arduino. IEf not, uncnmment'
A4 line by deleting the // before it. Bun the
S oagain to see a list of serial ports. Then R
S the 0 in between [ and ] to the number of the port
S/ that your Arduino iz connected to,
J/printiniserial. listl));

SAAtring arduinoPort = Jerial.list(i[1]:
port = new Jerialithiz, "COMZZ™, 9a00);

wvoid drawi() {
background(0) ;
if [(port.awvajilable() > 01 { /7 If data iz awvailable,

val = port.readl):; Sforead it and store it in wal
val = wap(wal, 0, 255, 0, height); // Convert the walue Designed Technische Universiteit
Intelligence e Eindhoven
; Group University of Technology

rect(40, wal-10, 360, 20);
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Serial Communication (Firmata)

 Introducing Firmata
e http://playground.arduino.cc/Interfacing/processing

Download

Library for Processing v2.0: processing2-arduino.zip (Updated 6 Nov. 2013)

(properties file here: processing2-arduino.txt)

Library for Processing v1.5: processing-arduino.zip (Updated 11 Nov. 2011)

(properties file here: processing-arduino.txt)

Note: if you run Linux, you need to change Arduino.jar into arduino.jar, because Linux is
case sensitive and it does not work if you don't change this letter (Arduino jar is in the

folder "library” of this Processing Library).

Designed Technische Universiteit
Intelligence e Eindhoven
Group University of Technology
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http://playground.arduino.cc/Interfacing/processing

Serial Communication (Firmata)

Instructions

1. Unzip the library and copy the "arduino” folder into the "libraries” sub-folder of your
Processing Sketchbook. (You can find the location of your Sketchbook by opening the
Processing Preferences. If you haven't made a "libraries” sub-folder, create one.)

2. Run Arduino, open the Examples > Firmata > StandardFirmata sketch, and upload it to the
Arduino board.

3. Configure Processing for serial: http://processing.org/reference/libraries/serial/

4. In Processing, open one of the examples that comes with with the Arduino library.

5. Edit the example code to select the serial port used by Arduino. Specifically, change the

@] inthisline
arduino = new Arduino(this, Arduino.list()[@], 57600);
To find the correct item in the array, run this code in Processing:

import processing.serial.®;
import cc.arduilno.®;
println{Azxduinc.list()});
The output window will enumerate your serial ports. Select the number corresponding to

the serial port in your Arduino environment found under Tools > Serial Port.

Vesigned Technische Universiteit
Intelligence I U e Eindhoven
Group University of Technology
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Serial Communication (Firmata)

 Introducing Firmata

Example

import processing.serial.*;

import coc.arduinc.*;

Arduine arduinoc:
int ledPin = 13:

vold setup()

{
Sfprintln{irduing.list ()}
arduinoc = new Arduinc(this, Arduinc.list() [0], 57

arduino.pinMode (1edPin, Arduinc.OUTEUT);

vold draw()

i
arduinc.digitalWrite {1ledPin, Arduinc.HIGH);
delay (1000} ;

arduinc.digitalWrite (ledPin, Arduinc.LOW);

delay (1000) ; Designed Technische Universiteit
Intelligence e Eindhoven
J Group University of Technology
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Serial Communication (Firmata)
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Arduino €= notebook

If the Baud Rate = 9600 bps,
then the Time/Bit = 1/9600 s

USB cable
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Arduino €= notebook

ONINQ¥Y

If the Baud Rate = 9600 bps,
then the Time/Bit = 1/9600 5

Start Bit
Stop Bit
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Arduino €= notebook

If the Baud Rate = 9600 bps,
then the Time/Bit = 1/9600 s

\ USB cable
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Socket communication

Server Client

Computer 1 Computer 2
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Ways to connect to Internet
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Possibilities

 Make sensors available for reading worldwide

 Make actuators available worldwide

 Send sensor values to server location where it can be
read by many.

s/ fively.comydev Tutorials, arduing_wi-f

Arduino WiFi

Introduction:

o just about

Hardware
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https://xively.com/dev/tutorials/arduino_wi-fi/
https://xively.com/dev/tutorials/arduino_wi-fi/

Additional Resources

You may look at:
* Processing Electronics tutorial
https://processing.org/tutorials/electronics/
Processing Network tutorial
https://processing.org/tutorials/network/
e Tutorial serial communication Arduino — Processing
https://www.youtube.com/watch?v=g0pSfyXOXj8&feature=kp
e Tutorial wireless communiation (Zigbee)
https://www.youtube.com/watch?v=vKVNmMA8C6mMS3
e Xively/Pachube/Cosm
http://xively.com/, https://xively.com/dev/tutorials/
e ESP8266
http://www.instructables.com/id/ESP8266-mini-Tutorial/?ALLSTEPS
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https://processing.org/tutorials/electronics/
https://processing.org/tutorials/network/
https://www.youtube.com/watch?v=g0pSfyXOXj8&feature=kp
https://www.youtube.com/watch?v=vKVNmA8C6m8
http://xively.com/
https://xively.com/dev/tutorials/
http://www.instructables.com/id/ESP8266-mini-Tutorial/?ALLSTEPS

That was Arduino
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