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Why Arduino?

Physical Computing

e uses electronics

e to prototype new materials

o for designers and artists.
Tinkering

Patching

Community

 Blog, Forum, Playground (wiki)
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Hardware

Arduino Uno Arduino Lil}'Pad Arduino Ethernet Arduino Nano Arduino BT Arduino Mini

Axininn Mon 0o Arduino BT Arduino Mini USB/Serial Light Adapter Arduino Pro Mini

Arduino Mega ADK

USB/Serial Light Adapter Arduino Pro Mini
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UNO

Microcontroller

Operating Voltage

Input Voltage (VIN) (recommended)
Input Voltage (limits)

Digital I/0O Pins

Analog Input Pins

DC Current per 1/0 Pin

DC Current for 3.3V Pin

Flash Memory

SRAM (Static RAM)

EEPROM (Electrically erasable
programmable ROM)

Clock Speed

Department of Industrial Design

ATmega328
5V

7-12V

6-20V

14 (of which 6 provide PWM output)
6

40 mA

50 mA

32 KB (ATmega328) of which 0.5 KB
used by bootloader

2 KB (ATmega328)
1 KB (ATmega328)

16 MHz
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UNO

 Power: USB Power supply (5V)
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UNO

 Power: external power supply (7V-12V)
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UNO

 Power: VIN, input or supply, depending on external
power source. (7-12V)
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 Power: 5V supply
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UNO

 Power: 3.3V supply
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UNO

 Power: GND pins
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UNO

« Digital I/0O Pins 14 (of which 6 provide PWM output)
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UNO

« Digital I/0O Pins 14 (of which 6 provide PWM output)
« PWM (Pulse-width modulation)
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UNO

« Serial: 0 (RX) and 1 (TX)
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UNO

e 6 analog inputs, 10 bits of resolution (i.e. 1024
different values)
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UNO

 AREF: Reference voltage for the analog inputs
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UNO

» Reset. LOW to reset the microcontroller
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Software: IDE

e http://arduino.cc/en/Main/Software

| Technische Universiteit
ce e Eindhoven
University of Technology
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http://arduino.cc/en/Main/Software

Driver Installation and Port Identification

» Refer to the instructions in
o “Getting Started with Arduino”, page 23-26

095|gned Technische Universiteit
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Breadboard




Color coding of the resistors

L B 1% S0
01z +2v IR |
0 Al 0| &
1 107 Eioz] [ 1]
2 I
3 [
4 [ Yellow IL EHH%EI!FE Léé& Exnﬁlﬁz lEé gTh EEH%I?'LIIS
5 ] Green
6 Jl Blue l [ [ EETE i |
7 I Purple HE T z2|z]z[x100 Eﬂﬂm
8 [ Grey DEII:I El El El BRI El El El EREEIE
9 [ White [#][#][<10000] [2][g][8][F10000] (2] [#] [#] [ 10000]
II_ ElEEl[=10] El E] [E] [=10]
+1% [ Brown w 1000000
+2% [l Red HEED HEH HEH
*5% [ ] Gold [El[E][=100] EIEE [E][E] [E]
+10% [ ] Silver [=1[5] ElEE) El|ElE]
Color Codes 4 Band Resistors | 5 Band Besistors | 6 Band Resistors
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Really getting started

Sense,/ Perceive
|ensors /‘\/J \

___H‘“'h———__ | I\
/ Behavior
(software) (/

"‘”\/’“h/
Actuators

Act./React
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Blinking an LED

* File>Examples>Basics>Blink

e LED: light-emitting diode
(@ Biink | Arduino 0022 -—ilglélg1

File Edit Sketch Tools Help

Blink
Turns on an LED on for one second, then off for one second, repe

This exanple code i3 in the public domain.
L

void setup () {
Jf initialize the digital pin az an output.
/¢ Pin 13 has an LED comnnected on most Arduino boards:
pinMode (13, OUTPUT):

¥

void loop () !
digitalllrite (13, HIGH): set the LED on
delay(1000) wait for a second
digitalllrite (13, LOW); set the LED off
delay(1000) wait for a second

Technische Universiteit
e Eindhoven
University of Technology

12-12-2012 PAGE 24

Department of Industrial Design



Blinking an LED
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Blink an LED

» #define LED 13

#define LED 13

vold =setup() |
S/ dinitialize the digital pin asz an output.
A4 Pin 13 has an LED comnected on most Arduino boards:
pinMode (LED, OUTEUT) :

vold loop() !
digitalllrite (LED, HIGH]) £4 set the LED on

delay (1000 ; A5 wait for a second
digitalllrite (LED, LOT ; 44 set the LED off
delay (1000 ; A5 wait for a second

Technische Universiteit
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Button to control the LED

* File>Examples>Digital>Button
(@ sutton) avuino 022 e ]

File Edit Sketch Tools Help

W

Button

Turnz on and off a light emitting diode (LED) connected to digital=
pin 13, when pressing a pushbutton attached to pin 2. 1

The circuit:

* LED attached from pin 13 to ground

* pushbutton attached to pin 2 from +35V

* 10K reszistor attached to pin 2 from ground

* Note: on most Arduinos there iz already an LED on the board
attached to pin 13.

created Z0O05
by DojoDave <http: /Jwmmr, 090, orge
wodified 28 Oct 2010

br Tom Trine
4|
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Button to control the LED
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Button to control the LED

A constants won't change. They're used here to

Af zet pin numbhers:

const int buttonPin = 2: A4 the mumber of the pushbutton pin
const int ledPin = 13; A4 the mumber of the LED pin

Af wariables will change:
int buttonitate = 0; A4 wariable for reading the pushbutton status

volid setup () {
A 1nitiali=ze the LED pin as an output:
pinMode (ledPin, OUTPUT) :
A dinitialize the pushbutton pin as an input:
pinfode (buttonPin, INPTUT);

Technische Universiteit
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Button to control the LED

vold loop ()
A5 read the state of the pushbutton walue:
buttonitate = digitalFead(buttonPin):

A7 check if the pushbutton is pressed.
A4 1f it is, the buttonstate is HIGH:
if [(button3tate == HIGH] {

A4 turn LED on:

digitalllrite (ledPin, HIGH) :
[
else {

A4 turn LED off:

digitalllrite (ledPin, LOW :

Department of Industrial Design
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Analog /O

* File>Examples>Analog>Analoglnput

e Instead of a potentiometer, we use a light sensor
R e )

File Edit Sketch Tools Help

Analog Input

Demonstrates analog input by reading an analog sensor on analog pin 0
turning on and off a light emitting diode(LED) connected to digital
The amount of time the LED will be on and off depends on

the walue obtained by analogRead().

The circuit:

* Potentiometer attached to analog input 0

* center pin of the potentiometer to the analog pin
* one side pin (either one) to ground

* the other zide pin to +5%
*
*

LED anode (long leg) attached to digital output 13
LED cathode (short leg) attached to ground

* Note: because most Arduinos hawe a built-in LED attached
to pin 13 on the board, the LED iz optional.

Created by Dawid Cuartielles
Modified 4 Zep Z010
By Ton Igoe

This example code is in the public domain.

4| 11
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Analog /O
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Analog /O

int sensorPin = A40; 7 select the input pin for the potentiometer
int ledPin = 13; ff select the pin for the LED
int sensorValue = 0; /7 wariable o store the walue coming from the sensor

vold setup() |
A4 declare the ledPin as an OUTPUT:
pinMode (ledPin, OUTPIT)

vold loop () |
A4 read the walue from the sSensor:
sensorValue = analogEeadi{sensorPin) ;
A turn the ledPin on
digitallrite (ledPin, HIGH) :
S/ stop the program for <£sensorValue> milliseconds:
delayi(zensorvalue) ;
A/ turn the ledPin off:
digitallrite(ledPin, LOW):
S/ stop the program for for <sensorWValue> milliseconds:

delayisensorvValue) ;
} echnology

12-12-2012 PAGE 33
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Analog /O

int sensorPin = 40; A4 select the input pin
int ledPin 4_11; AF select the pin for the LED
int sensorValue = 0; J/ wariable to ztore the walue coming from tThe zenszor

vold setup() |
Sf declare the ledPin as an O0UTPUT:
pinMode(ledPin, OUTPUT) :

void loop () {

A4 read the walue from the sensor:
sensorvValue = analogBead(sensorPin) ;
S turn the ledPin on

analogiirite {ledPin, sensorValuel'd)|:

Technische Universiteit
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Serial Communication

 We are going to use the Serial library from
Processing to talk to Arduino
o http://processing.orqg/referencel/libraries/serial/index.html

* In Processing
- File>Examples>Books>Getting Started>Ex_11 06
« You can not run this program in Processing
- Copy the code to Arduino software, upload to Arduino.

Designed Technische Universiteit
Intelligence e Eindhoven
Group University of Technology
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http://processing.org/reference/libraries/serial/index.html

Serial Communication

A/ Ewample 11-06 from "Getting Started with Processing”
A by Beas & Fry. 0'BEeilly / Make 2010

A Note: This iz code for an Arduino board, not Processing

int sensorPin = 0; /S Select input pin
int wal = 0;

4

void setup () { The 'BYTE' keyward is no londger supparted.
Serial . .bhegin(9a00) ;

vold loop() |

wval = analogRead(sensorPin) / 4; /7 FEead walue from sSenszor
serial.printiwal, BE¥YTE): // Frint wariable to serial port
delay(100): 7/ Wait 100 milliseconds

b

Designed Technische Universiteit
Intelligence e Eindhoven
Group University of Technology
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Serial Communication

/¢ Example 11-06 from "Getting Started with P[4 comzs

S/ by Beas & Fry. 0'Eeilly / Make 2010 f

I

S Note: This iz code for an Arduino board, n|°

int sensorPin = 0; /7 Zelect input pin
int wal = 0;

volid setup() !

Serial.begin(9600); S/ Open serial port

-

vold loop() |

val = analoghead{sensorPin] / 4;

Autoscroll

-:Cérfiage return v EIEUU baud

S8 RBead walue from sensor

Ferial.println(wal) ;

A4 Print wariahle to serial port

delavy(100); S/ Wait 100 millizeconds

Department of Industrial Design
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Serial Communication

A4 Example 11-06 from "Getting Started wlthmmzzﬂ_

A by Beas & Fry. 0'Beilly / Make Z010 [ ém

Z]_abaaa”_ ~\[ZYXVIUWY\~"aaa" " _~\[ZYWVUIVE[~"abaa" " _

A Note: This iz code for an Arduino board,

int sensorPin = 0; /7 Select input pin
int wal = 0;

vold setup () {
Serial.begin(9e00),; /S Open serial port

T i

i m | »

Autoscroll .:Carria»ge return - EEIEUIIJ baud

vold loop() |
val = analogRead(sensorPin) / 4; /) BEead walue Lrom sensor
Serial.write(wval); J/ Print wariable to serial port
delay (100) ; 77 Wait 100 milliseconds

|
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Serial Communication

* In Processing
 FilesExamples>Books>Chapter 11>Ex 11 07

Designed Technische Universiteit
Intelligence e Eindhoven
Group University of Technology
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Serial Communication

import processing. serial.*;

Aerial port; FF Create object from Serial class
float wal; S/ Data received from the serial port

void setup ()
size (440, 220):
A4 TMPORTANT NOTE:
S4 The first serial port retriewed by Serial.listi)
4 should be your Arduino. If not, uncomment the next
S5 line by deleting the /7 before it. Bun the sketch
S5 oagain to see a list of serial ports. Then, chatge
SO the 0 in between [ and ] to the number of the port
F rhunnr Aty d= connected o
Siprintlni(derial.list());
§tring arduinofort = §Erial.listi][ﬂ];
port = new Jerial(thiz, arduinoPort, 9600);

vold drasr() !
if [(port.awvailable() > 0) { 7/ If data iz awvailable,
val

port.readi]: AP read it and store it in wal

val map (wal, 0, 55, 0, height); // Convert the walus TU

Technische Universiteit
} nce

e Eindhoven
University of Technology
recti(d0, wal-10, 360, Z0):
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Serial Communication

Nimport processing.serial.®;

Serial port: JF/ Create object from 3erial clas
float wal: A7 Data received from the serial

vold setup () !
gize (440, 220): I
A4 IMPORTANT NOTE:
S/ The first serial port retriewed by 3erial.
A4 oshould be vyour Arduino. If not, uncomment
S5 line by deleting the // before it. RFun the
S/ again to see a list of serial ports. Then, change
S5 the 0 in between [ and ] to the nmumber of the port
A that wour Arduinog iz connected to.
printlni{ierial.list{)):
String arduinoPort = Jerial.lizt(i[1l]:
port = new Seriali(this, arduinoPort, 2600 ;

vold dravw() |
if [port.available() = 0) { // If data is awvailable,

wal = port.read(): SSPoread it and store it in wal
wal = mapiwal, 0, 255, 0, height): J/ Conwvert the walue  signed Technische Universiteit
elligence e Eindhoven
) up University of Technology

rect(40, wal-10, 360, 20);
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Serial Communication

import processing.serial.®:

Serial port: S/ Create object from Jerial clas
float wal: 4 Data recejived from the serial

vold setup() ! |
size (440, 2Z20); i
A4 IMPORTANT HNOTE:
/¢ The first serial port retriewed by Serial.]
A should be wour Arduino. If not, uncomnment
A5 line by deleting the /) bhefore it. Bun the
A5 again to see a list of serial ports. Then, —
A/ the 0 in between [ and ] to the number of the port
A4 that your Arduino iz connected to.
printlni(ferial.list()):
string arduinoPort = Jerial.list{)[1l]:
port = new 3erial (this, arduinoPort, 9600);

vold draw() {
background(0) ;
i1f [port.awvailable() > 0] §{ // If data iz awvailable,

wal = port.read(): Sforead it and store it in wal
val = map(wval, 0, 255, 0, height); // Convert the walue | Designed Technische Universiteit
Intelligence Eindhoven
' Group University of Technology

rect(dl, wal-10, 360, 20);
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Serial Communication

import processing.serial.™*;

Serial port; S Create object from Serial cla:
float wal; A4 Dara receiwved from the serial

vold setupi() {

size (440, 220):

S4 IMPORTANT HNOTE:
A4 The first serial port retriewed by Serial.f
4 should be your Arduino. If not, uncnmment'
A4 line by deleting the // before it. Fun the
S/ again to see a list of serial ports. Then E—
4 the 0 in between [ and ] to the number of the port
4 that your Arduino iz conrnected to.
Aiprintlniserial.list()):

SAAtring arduinoPort = Jerial.list(i[1]:
port = new Aerial(thi=s, "COMZZT™, 9600):

wvold draw() |
background (0] ;
if [(port.awajilable() > 01 { J/ If data iz awailable,

val = port.readl) Aforead it and store it in wval
val = wap(wal, 0, 255, 0, height); // Convert the walue Designed Technische Universiteit
Intelligence Eindhoven
; Group University of Technology

rect(40, wal-10, 360, 20);
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Serial Communication (Firmata)

 Introducing Firmata
e http://playground.arduino.cc/Interfacing/processing

Download

Library for Processing v2.0: processing2-arduino.zip (Updated 6 Nov. 2013)

(properties file here: processing2-arduino.txt)

Library for Processing v1.5: processing-arduino.zip (Updated 11 Nov. 2011)

(properties file here: processing-arduino.txt)

MNote: if you run Linux, you need to change Arduino.jar into arduino.jar, because Linux is
case sensitive and it does not work if you don't change this letter (Arduino jar is in the

folder "library” of this Processing Library).

Technische Universiteit
Eindhoven
University of Technology
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http://playground.arduino.cc/Interfacing/processing

Serial Communication (Firmata)

Instructions

1. Unzip the library and copy the "arduino” folder into the "libraries” sub-folder of your
Processing Sketchbook. (You can find the location of your Sketchbook by opening the
Processing Preferences. If you haven't made a "libraries” sub-folder, create one.)

2. Run Arduino, open the Examples > Firmata > StandardFirmata sketch, and upload it to the
Arduino board.

3. Configure Processing for serial: http://processing.org/reference/libraries/serial/

4. In Processing, open one of the examples that comes with with the Arduino library.

5. Edit the example code to select the serial port used by Arduino. Specifically, change the

[@] inthisline
arduinoe = new Arduino(this, Arduino.list()[@], 57600);
To find the correct item in the array, run this code in Processing:

import processing.serial.®;
import cc.arduino.®;
println{Azxduinc.list()});
The output window will enumerate your serial ports. Select the number corresponding to

the serial port in your Arduino environment found under Tools > Serial Port.

Vesigned Technische Universiteit
B Intelligence I U e Eindhoven
Group University of Technology
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Serial Communication (Firmata)

 Introducing Firmata

Example

import processing.serial.*;

import coc.arduinc.*;

Lrduine arduino:

int ledPin = 13;

vold setup()

{
Sfprintln (Arduinc.list());
arduinoe = new Arduinc{this, Arduinc.list({) [0], 57
arduino.pinMode (ledPin, Arduinc.OUIEUT);

vold draw()

i
arduino.digitalWrite (ledPin, Arduinc.HIGH);
delay (1000} ;

arduino.digitalWrite (ledPin, Arduino.LOW);

delay (1000) ; Designed Technische Universiteit
Intelligence e Eindhoven
! Group University of Technology
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Serial Communication (Firmata)




Arduino €= notebook

>>>> P>
hEwhHS
INT 20TWNY

ATWAT NI BOWH
23" GaEnauy“wan

ONINQyY

(~AMd) VL1910

[ L
NwhuaN R0

If the Baud Rate = 9600 bps,
then the Time/Bit = 1/9600 s

Start Bit
Stop Bit

USB cable
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Arduino €= notebook

ATWAT T BOWH
22" GnEnaEY“nan

NOTITO3ONS

If the Baud Rate = 9600 bps,
then the Time/Bit = 1/9600 5

Designed Technische Universiteit
Intelligence e Eindhoven
Group University of Technology

/ Department of Industrial
Desian




Arduino €= notebook

>>>> P>
hEwhHS
INT 20TWNY

ATWAT NI BOWH
23" GaEnauy“wan

ONINQyY

(~AMd) VL1910

[ L
NwhuaN R0

If the Baud Rate = 9600 bps,
then the Time/Bit = 1/9600 s

Start Bit
Stop Bit
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http://arduino.cc/en/Serial/Print

Socket communication

Server Client

Computer 1 Computer 2
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Socket communication

IP address
\

N

Server Client

Computer 1 Computer 2
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Socket communication

192.168.1.23 192.168.\1.25
\
\ N
Server Client

Computer 1 Computer 2
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Socket communication

192.168.1.23 Port number 192.168.\1.25
\
\ > 1023 N
Server Client

Computer 1 Computer 2
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Socket communication

192.168.1.23:5012 192.168.1.25
\\ \\
Server Client

Computer 1 Computer 2
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Ways to connect to Internet
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Ways to connect to Internet

Wifi Module
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Ways to connect to Internet
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Ways to connect to Internet
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Ways to connect to Internet

Wifi Module
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Ways to connect to Internet

---------\
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Ways to connect to Internet
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Ways to connect to Internet
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Ways to connect to Internet
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Possibilities

 Make sensors available for reading worldwide

 Make actuators available worldwide

 Send sensor values to server location where it can be
read by many.

s/ fively.comy/dev tutoriaks/arduina_

Arduino WiFi

Introduction:

cral Arduing

o just about

Hardware
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https://xively.com/dev/tutorials/arduino_wi-fi/

Additional Resources

You may look at:

e Tutorial serial communication Arduino — Processing
https://www.youtube.com/watch?v=g0pSfyXOXj8&feature=kp

e Tutorial wireless communiation (Zigbee)
https://www.youtube.com/watch?v=vKVNmMASC6mM8

e Xively/Pachube/Cosm

http://xively.com/, https://xively.com/dev/tutorials/
e ESP8266
http://www.instructables.com/id/ESP8266-mini-Tutorial/?ALLSTEPS

And many many more...
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https://www.youtube.com/watch?v=g0pSfyXOXj8&feature=kp
https://www.youtube.com/watch?v=vKVNmA8C6m8
http://xively.com/
https://xively.com/dev/tutorials/
http://www.instructables.com/id/ESP8266-mini-Tutorial/?ALLSTEPS

That was Arduino
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